Minor problems with Android Market

For the past few months, I did not know why the Android Market would say "Your device is not compatible with this item" on existing apps that I already installed. Ironically, one of the incompatible apps was Google+, which should definitely be compatible with my Nexus One. I wasn't able to find a reason behind this until today.

A few possible reasons might be that I'm running Cyanogenmod 7 instead of the usual stock Android OS. But that shouldn't be the case, since Tiffany's HTC Aria is also on CM7, and does not have any incompatibility issues. So online, some people said the new Market app has a new device policy that is interfering, and uninstalling the Market update along with clearing the Market app cache should help. I tried this method and I was able to update all my apps through an old Market app version! Here's a screenshot of my success:


Here's a detail my my process:

Go to Settings -> Applications -> Market

Uninstall Updates

Clear Cache

Open Android Market. The app may crash, so try again if it does. You should now be in the older version of Market! In addition, you should see any possible updates from your apps.